Installation

Requirements

CraftBook requires a version of the Minecraft server that supports the Bukkit API, which includes PaperMC and Spigot. The official Minecraft server is not supported.

Note

Newer versions of CraftBook are available that support the Sponge API, they can be found here.

Installation

CraftBook can be downloaded from the EngineHub site.

  1. If you downloaded CraftBook as a ZIP file, extract it to find “CraftBook.jar” inside. Otherwise, you should already have a .jar file.
  2. In your server folder, create a “plugins” folder if one does not yet exist.
  3. Copy the CraftBook .jar file into the plugins folder.
  4. Start your server.

Note: CraftBook requires that WorldEdit is installed.

Check your server log for errors. If you encounter errors, see the Getting Help page.